POJ2431 優先隊列+貪心 - biaobiao88

来源:https://www.cnblogs.com/biaobiao88/archive/2019/11/03/11789263.html
-Advertisement-
Play Games

以下代碼可對結構體數組中的元素進行排序,也差不多算是一個小小的模板了吧 運行結果: 也可以這樣 對優先隊列的應用,POJ2431是一個很好的題目,此題用了優先隊列+貪心 Expedition Time Limit: 1000MS Memory Limit: 65536K Total Submissi ...


以下代碼可對結構體數組中的元素進行排序,也差不多算是一個小小的模板了吧

#include<iostream>
#include<algorithm>
using namespace std;
struct node
{
	int x;
	int y;
	bool operator<(const node &a) const//此操作是對操作符"<"進行重構 
	{
		return x < a.x;//對結構體數組x進行從大到小排序 
//		return y > a.y;//對結構體數組y進行從大到小排序 
	}
}s[100];

//bool cmp(int x,int y)//這個重構函數不能用在結構體數組中 
//{
//	return x > y;
//}

int main()
{
	int n;
	cin >> n;
	for(int i = 0;i < n;i++)
		cin >> s[i].x >> s[i].y;
	
	sort(s,s+n);
	for(int i = 0;i < n;i++)
		cout << s[i].x << " " << s[i].y << endl;
	cout << endl;
	return 0;
}

運行結果:

 

 

 也可以這樣

#include<iostream>
#include<algorithm>
using namespace std;
struct node
{
    int x;
    int y;
    bool operator<(const node &a) const 
    {
        return x > a.x; 
    }
}s[100];

bool cmp(node m,node n)
{
    m.x < n.x;
}

int main()
{
    int n;
    cin >> n;
    for(int i = 0;i < n;i++)
        cin >> s[i].x >> s[i].y;
    
    sort(s,s+n);
    for(int i = 0;i < n;i++)
        cout << s[i].x << " " << s[i].y << endl;
    cout << endl;
    return 0;
}

對優先隊列的應用,POJ2431是一個很好的題目,此題用了優先隊列+貪心

Expedition
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 29720   Accepted: 8212

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.

Input

* Line 1: A single integer, N

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS:

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively.

OUTPUT DETAILS:

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

Source

USACO 2005 U S Open Gold 思路:貪心思路為,在假設汽車一路向前,在途中有經過加油站的話,把加油站進行排序,符合條件的加油站中的汽油從大到小排序,存到優先隊列中,在汽車用完時,即隨時可以在隊列的隊頭取汽油,使得汽車儘可能加最多的汽油,停最少次
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
struct node
{
    int dis;
    int fuel;
    bool operator<(const node &a) const//此重構操作,請參考上面的代碼 
    {
        return dis > a.dis;//返回dis,說明是對dis這個數組進行排序操作 
    }
}stop[10005];

priority_queue<int> que;

int main()
{
    int n,l,p;
    cin >> n;
    for(int i = 0;i < n;i++)
        cin >> stop[i].dis >> stop[i].fuel;
    cin >> l >> p;
    int ans = 0;
    sort(stop,stop + n);//對加油站距離dis數組進行從大到小排序 
    que.push(p);//隊列自動從大到小排序,即排序汽油p 
    int temp = 0;
    while(l > 0 && !que.empty())//卡車未到達終點並且卡車在當前汽油用完前有路過加油站 
    {
        ans++;//卡車停下加一次油計數器 
        l -= que.top();//加油,更新一次汽油用盡後距離終點的距離 
        que.pop();//刪除已用的加油站的汽油 
        while(l <= stop[temp].dis && temp < n)//卡車距離終點的距離小於等於最近加油站的距離並且這個加油站的位置在終點加油站前面,這裡假設終點也為一個加油站。//l <= stop[i].dis意思是卡車能經過離它最近的一個加油站,如果大於的話,說明卡車停下時沒有加油站可加油  
            que.push(stop[temp++].fuel);//將經過的加油站壓入優先隊列,要使用的時候就取隊頭元素(隊頭中存的汽油最大) //如果經過加油站,則一定要將該加油站的可加油量添加到優先隊列當中 
    }//temp++說明離卡車最近的加油站,卡車繼續往前開,加油站點也依次往後,所以變數temp需要自增
    if(l > 0)//如果卡車距離終點的距離還大於0的話,即通過不了終點 
        cout << "-1" << endl;
    else
        cout << ans - 1 << endl;//在起點深度時候記為一次加油,這裡需要減去1 
    return 0;
}

其中代碼有詳細的註釋,希望註釋能加深理解

代碼參考於:博客園-小小菜鳥


您的分享是我們最大的動力!

-Advertisement-
Play Games
更多相關文章
  • 新聞 "Elmish.WPF教程" "介紹Orleans 3.0" "GC配置歷史" "介紹ONNX運行時1.0" "介紹微軟Q&A(預覽)" "使用App中心持續佈署與監控你的UWP,WPF與Windows Forms應用" 視頻及幻燈片 "介紹F " ".NET設計審查:ARM Intrinsi ...
  • [TOC] 簡介 SQLAlchemy是一個基於Python實現的ORM框架。該框架建立在 DB API之上,使用關係對象映射進行資料庫操作,簡言之便是:將類和對象轉換成SQL,然後使用數據API執行SQL並獲取執行結果。 安裝 組成部分 Engine:框架的引擎 Connection Poolin ...
  • 一、線程安全 線程安全的概念:當多個線程訪問某一個類(對象或方法)時。這個類始終都能表現出正確的行為那麼這個類(對象或方法)就是線程安全的。 synchronized:可以在任何對象及方法上加鎖,而加鎖的這段代碼稱為“互斥區”或“臨界區” 示例:【com.study.base.thread.a_sy ...
  • 二叉查找樹是將一組無序的數據構建成一顆有序數據的樹,其設計思想與二分法類似。很好的提高了海量數據查找效率,使得由從頭遍歷到尾的方式轉為二分查找的方式,時間複雜度從O(n)降低為O(log(n))。 ...
  • 搭建 vue cli 腳手架 1. 安裝 git 2. 安裝 node 並配置環境變數,使用 zip 版本 3. 使用淘寶鏡像 4. 安裝 node 模塊 cnpm 5. 全局安裝 vue cli 6. 使用 webpack 骨架初始化應用 ,就像 maven 骨架一樣 7. 運行項目 引入 Ele ...
  • 描述:Spring框架中,@Resource註解報錯,在書寫時沒有自動提示 解決方法:因為maven配置文件的pom.xml文件中缺少javax.annotation的依賴,在pom.項目路中加入依賴即可 <!-- Javax Annotation --> <dependency> <groupId ...
  • 0. 為什麼人人都討厭寫單測 在之前的關於 "swagger" 文章里提到過, 程式員最討厭的兩件事,一件是別人不寫文檔,另一件就是自己寫文檔。這裡如果把文檔換成單元測試也同樣成立。 每個開發人員都明白單元測試的作用,也都知道代碼覆蓋率越高越好。高覆蓋率的代碼,相對來說出現 BUG 的概率就越低,在 ...
  • 定義:我們如何把現實中大量而複雜的問題以 特定的數據類型 和 特定的存儲結構 保存到主記憶體器中(記憶體),以及在此基礎上為實現某個功能(比如查找某個元素,刪除某個元素,對所有元素進行排序)而執行的相應操作,這個相應的操作也叫演算法 數據結構 = 個體 + 個體的關係 演算法 = 對存儲結構的操作 演算法:解 ...
一周排行
    -Advertisement-
    Play Games
  • 移動開發(一):使用.NET MAUI開發第一個安卓APP 對於工作多年的C#程式員來說,近來想嘗試開發一款安卓APP,考慮了很久最終選擇使用.NET MAUI這個微軟官方的框架來嘗試體驗開發安卓APP,畢竟是使用Visual Studio開發工具,使用起來也比較的順手,結合微軟官方的教程進行了安卓 ...
  • 前言 QuestPDF 是一個開源 .NET 庫,用於生成 PDF 文檔。使用了C# Fluent API方式可簡化開發、減少錯誤並提高工作效率。利用它可以輕鬆生成 PDF 報告、發票、導出文件等。 項目介紹 QuestPDF 是一個革命性的開源 .NET 庫,它徹底改變了我們生成 PDF 文檔的方 ...
  • 項目地址 項目後端地址: https://github.com/ZyPLJ/ZYTteeHole 項目前端頁面地址: ZyPLJ/TreeHoleVue (github.com) https://github.com/ZyPLJ/TreeHoleVue 目前項目測試訪問地址: http://tree ...
  • 話不多說,直接開乾 一.下載 1.官方鏈接下載: https://www.microsoft.com/zh-cn/sql-server/sql-server-downloads 2.在下載目錄中找到下麵這個小的安裝包 SQL2022-SSEI-Dev.exe,運行開始下載SQL server; 二. ...
  • 前言 隨著物聯網(IoT)技術的迅猛發展,MQTT(消息隊列遙測傳輸)協議憑藉其輕量級和高效性,已成為眾多物聯網應用的首選通信標準。 MQTTnet 作為一個高性能的 .NET 開源庫,為 .NET 平臺上的 MQTT 客戶端與伺服器開發提供了強大的支持。 本文將全面介紹 MQTTnet 的核心功能 ...
  • Serilog支持多種接收器用於日誌存儲,增強器用於添加屬性,LogContext管理動態屬性,支持多種輸出格式包括純文本、JSON及ExpressionTemplate。還提供了自定義格式化選項,適用於不同需求。 ...
  • 目錄簡介獲取 HTML 文檔解析 HTML 文檔測試參考文章 簡介 動態內容網站使用 JavaScript 腳本動態檢索和渲染數據,爬取信息時需要模擬瀏覽器行為,否則獲取到的源碼基本是空的。 本文使用的爬取步驟如下: 使用 Selenium 獲取渲染後的 HTML 文檔 使用 HtmlAgility ...
  • 1.前言 什麼是熱更新 游戲或者軟體更新時,無需重新下載客戶端進行安裝,而是在應用程式啟動的情況下,在內部進行資源或者代碼更新 Unity目前常用熱更新解決方案 HybridCLR,Xlua,ILRuntime等 Unity目前常用資源管理解決方案 AssetBundles,Addressable, ...
  • 本文章主要是在C# ASP.NET Core Web API框架實現向手機發送驗證碼簡訊功能。這裡我選擇是一個互億無線簡訊驗證碼平臺,其實像阿裡雲,騰訊雲上面也可以。 首先我們先去 互億無線 https://www.ihuyi.com/api/sms.html 去註冊一個賬號 註冊完成賬號後,它會送 ...
  • 通過以下方式可以高效,並保證數據同步的可靠性 1.API設計 使用RESTful設計,確保API端點明確,並使用適當的HTTP方法(如POST用於創建,PUT用於更新)。 設計清晰的請求和響應模型,以確保客戶端能夠理解預期格式。 2.數據驗證 在伺服器端進行嚴格的數據驗證,確保接收到的數據符合預期格 ...