LCA最近公共祖先-- HDU 2586

来源:https://www.cnblogs.com/chen9510/archive/2019/05/04/10809886.html
-Advertisement-
Play Games

題目鏈接 Problem Description There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this ...


題目鏈接

 

Problem Description There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.   Input First line is a single integer T(T<=10), indicating the number of test cases.
  For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated by a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.
  Next m lines each has distinct integers i and j, you are to answer the distance between house i and house j.   Output For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.   Sample Input 2 3 2 1 2 10 3 1 15 1 2 2 3     2 2 1 2 100 1 2 2 1   Sample Output 10 25 100 100

 

題意:有一棵有n個節點的樹,每條邊上有一個權值代表這兩個點之間的距離,現在m次詢問:從節點a到節點b的路徑長?

思路:預處理所有節點到根節點(定為節點1)的距離,以及所有節點的祖先信息(fa[i][j]表示節點 i 向上距離為 (1<<j)的祖先節點編號),計算a和b到根節點的距離和,減去兩倍的最近公共祖先的到根節點的距離值。

代碼如下:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
const int N = 4e4 + 5;

int head[N], cnt;
struct Edge
{
    int to, next;
    int value;
}e[2 * N];

struct Node {
    int fa[20];
    int deep;
    int sum;
    bool state;
}node[N];

void insert(int u, int v, int value)
{
    e[++cnt].to = v;
    e[cnt].next = head[u];
    e[cnt].value = value;
    head[u] = cnt;
    e[++cnt].to = u;
    e[cnt].next = head[v];
    e[cnt].value = value;
    head[v] = cnt;
}
int cal(int x, int t)
{
    for (int i = 0; i <= 19; i++)
        if (t&(1 << i)) x = node[x].fa[i];
    return x;
}
void dfs(int x)
{
    node[x].state = 1;
    for (int i = 1; i <= 19; i++)
    {
        if (node[x].deep<(1 << i))break;
        node[x].fa[i] = node[node[x].fa[i - 1]].fa[i-1];///倍增處理祖先信息
    }
    for (int i = head[x]; i; i = e[i].next)
    {
        if (node[e[i].to].state) continue;
        node[e[i].to].deep = node[x].deep+ 1;
        node[e[i].to].fa[0] = x;
        node[e[i].to].sum = node[x].sum+e[i].value;
        dfs(e[i].to);
    }
}
int lca(int x, int y)///求lca
{
    if (node[x].deep<node[y].deep) swap(x, y);
    x = cal(x, node[x].deep - node[y].deep);
    for (int i = 19; i >= 0; i--)
        if (node[x].fa[i] != node[y].fa[i])
        {
            x = node[x].fa[i];
            y = node[y].fa[i];
        }
    if (x == y)return x;
    else return node[x].fa[0];
}

void init()
{
    cnt = 0;
    memset(head, 0, sizeof(head));
    memset(node, 0, sizeof(node));
}

int main()
{
    int T; cin >> T;
    while (T--)
    {
        init();
        int n, m; cin >> n >> m;
        for (int i = 0; i < n-1; i++) {
            int x, y, v; scanf("%d%d%d",&x,&y,&v);
            insert(x,y,v);
        }
        dfs(1);
        for (int i = 0; i < m; i++) {
            int x, y; scanf("%d%d",&x,&y);
            int pa = lca(x, y);
            int ans = node[x].sum - node[pa].sum + node[y].sum - node[pa].sum;
            cout << ans << endl;
        }
    }
    return 0;
}

 


您的分享是我們最大的動力!

-Advertisement-
Play Games
更多相關文章
  • 話不多說,一個是算時間的,還有一個是生成驗證碼的 驗證碼: ...
  • 一、引言 異常總是不可避免的,就算我們自身的代碼足夠優秀,但卻不能保證用戶都按照我們想法進行輸入,就算用戶按照我們的想法進行輸入,我們也不能保證操作系統穩定,另外還有網路環境等,不可控因素太多,異常也不可避免。 但我們可以通過異常處理機制讓程式有更好的容錯性和相容性,當程式出現異常時,系統自動生成E ...
  • web.xml部分 1.歡迎界面 2.字元編碼過濾器 3.springmvc配置 springmvc-serlvet.xml部分 1.InternalResourceViewResolver 視圖解析器 2.註解包掃描器 3.基礎配置和引入靜態資源配置 4.全局異常處理 5.文件上傳 ...
  • 一、指針 1、指針是一種存放記憶體地址的數據類型 2、指針的創建 typename * p;//空格可有可無 此時p的類型為(typename *) (*p)的類型為typename 初始化一個指針後,該指針變數會被存放在記憶體中的某個地址 指針創建時可以不初始化 3、對其賦值後,其對應記憶體位置存放的值 ...
  • golang 1.12 版本的自動補全問題 問題 golang 1.12 開始, 預設的 不再生成 pkg 文件. 所以對第三方庫的引用, 無法進行代碼的自動補全. 解決方法 會生成 pkg 文件夾和編譯文件 ...
  • java中的集合分成哪幾類? java中的集合常見面試題有哪些? java中的集合你不知道的那些事? ...
  • jupyter notebook的插件安裝及文本格式修改 1.jupyter notebook拓展插件安裝 啟動jupyter notebook : 打開控制台輸入命令 jupyter notebook 安裝Jupyter notebook extensions擴展插件: 1、pip install ...
  • Flask信號 信號是可以在固定的事件發生時執行某些事情 一個簡單的使用信號的例子: from flask import Flask,signals app = Flask(__name__) def signal_func(*args,**kwargs): print('信號') signals. ...
一周排行
    -Advertisement-
    Play Games
  • 移動開發(一):使用.NET MAUI開發第一個安卓APP 對於工作多年的C#程式員來說,近來想嘗試開發一款安卓APP,考慮了很久最終選擇使用.NET MAUI這個微軟官方的框架來嘗試體驗開發安卓APP,畢竟是使用Visual Studio開發工具,使用起來也比較的順手,結合微軟官方的教程進行了安卓 ...
  • 前言 QuestPDF 是一個開源 .NET 庫,用於生成 PDF 文檔。使用了C# Fluent API方式可簡化開發、減少錯誤並提高工作效率。利用它可以輕鬆生成 PDF 報告、發票、導出文件等。 項目介紹 QuestPDF 是一個革命性的開源 .NET 庫,它徹底改變了我們生成 PDF 文檔的方 ...
  • 項目地址 項目後端地址: https://github.com/ZyPLJ/ZYTteeHole 項目前端頁面地址: ZyPLJ/TreeHoleVue (github.com) https://github.com/ZyPLJ/TreeHoleVue 目前項目測試訪問地址: http://tree ...
  • 話不多說,直接開乾 一.下載 1.官方鏈接下載: https://www.microsoft.com/zh-cn/sql-server/sql-server-downloads 2.在下載目錄中找到下麵這個小的安裝包 SQL2022-SSEI-Dev.exe,運行開始下載SQL server; 二. ...
  • 前言 隨著物聯網(IoT)技術的迅猛發展,MQTT(消息隊列遙測傳輸)協議憑藉其輕量級和高效性,已成為眾多物聯網應用的首選通信標準。 MQTTnet 作為一個高性能的 .NET 開源庫,為 .NET 平臺上的 MQTT 客戶端與伺服器開發提供了強大的支持。 本文將全面介紹 MQTTnet 的核心功能 ...
  • Serilog支持多種接收器用於日誌存儲,增強器用於添加屬性,LogContext管理動態屬性,支持多種輸出格式包括純文本、JSON及ExpressionTemplate。還提供了自定義格式化選項,適用於不同需求。 ...
  • 目錄簡介獲取 HTML 文檔解析 HTML 文檔測試參考文章 簡介 動態內容網站使用 JavaScript 腳本動態檢索和渲染數據,爬取信息時需要模擬瀏覽器行為,否則獲取到的源碼基本是空的。 本文使用的爬取步驟如下: 使用 Selenium 獲取渲染後的 HTML 文檔 使用 HtmlAgility ...
  • 1.前言 什麼是熱更新 游戲或者軟體更新時,無需重新下載客戶端進行安裝,而是在應用程式啟動的情況下,在內部進行資源或者代碼更新 Unity目前常用熱更新解決方案 HybridCLR,Xlua,ILRuntime等 Unity目前常用資源管理解決方案 AssetBundles,Addressable, ...
  • 本文章主要是在C# ASP.NET Core Web API框架實現向手機發送驗證碼簡訊功能。這裡我選擇是一個互億無線簡訊驗證碼平臺,其實像阿裡雲,騰訊雲上面也可以。 首先我們先去 互億無線 https://www.ihuyi.com/api/sms.html 去註冊一個賬號 註冊完成賬號後,它會送 ...
  • 通過以下方式可以高效,並保證數據同步的可靠性 1.API設計 使用RESTful設計,確保API端點明確,並使用適當的HTTP方法(如POST用於創建,PUT用於更新)。 設計清晰的請求和響應模型,以確保客戶端能夠理解預期格式。 2.數據驗證 在伺服器端進行嚴格的數據驗證,確保接收到的數據符合預期格 ...