咳咳,這個是為了趕量 需要註意的就是輸入方式,別的也沒什麼難點 Problem Description Ignatius likes to write words in reverse way. Given a single line of text which is written by Igna ...
咳咳,這個是為了趕量
需要註意的就是輸入方式,別的也沒什麼難點
Problem Description Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.Input The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
Output For each test case, you should output the text which is processed.
Sample Input
3 olleh !dlrow m'I morf .udh I ekil .mca
Sample Output
hello world! I'm from hdu. I like acm.
這是題意
接下來放代碼
#include <iostream>
#include <cstdio>
#include <stack>
using namespace std;
int main(){
int n;
cin >> n;
getchar();
while(n--){
stack<char>cst;
while(1){
int ch=getchar();
if(ch==' '||ch=='\n'){
while(!cst.empty()){
cout << cst.top();
cst.pop();
}
if(ch==' ')cout << ' ';
else break;
}
else cst.push(ch);
}
cout << endl;
}
return 0;
}
OK