poj_3253 Fence Repair

来源:https://www.cnblogs.com/zi-qilin/archive/2018/08/10/9453519.html
-Advertisement-
Play Games

Fence Repair Description Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N ( ...


Fence Repair

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).   題意:要切N塊板子,將長度為L的板子切成兩塊花費L元,給出N塊板子的長度,求最小花費   解析:Huffman tree 思想,每次將最短的兩塊板子取出,再將兩者長度之和累加到費用中,再將兩者長度之和作為新一塊板子的長度並把這塊板子放入剩餘板子的集合中,重覆以上操作直到只剩一塊板子。 具體操作可以利用STL大法,強行優先隊列 代碼如下:

#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;
int n;
long long ans;
priority_queue<long long ,vector<long long>,greater<long long> > Q;
int main()
{
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
long long a;
scanf("%lld",&a);
Q.push(a);
}
while(Q.size()!=1)
{
long long u=Q.top();Q.pop();
long long v=Q.top();Q.pop();
ans+=(u+v);
u+=v;
Q.push(u);
}
printf("%lld",ans);
return 0;
}


您的分享是我們最大的動力!

-Advertisement-
Play Games
更多相關文章
  • declare @total int; declare @count int; set @count=0; SELECT @total=COUNT(1) FROM TB_JJ; create table #T ( rid int PRIMARY KEY, sys_guid NVARCHAR(40) ...
  • 傳統設計T(id,a,b,c,d,e,f,g,e,f.....),其中有一部分欄位是不經常變化的,有一部分是經常變化的. 拆表思路: T(id,a,b,c,d): 一些不怎麼變化又經常查詢的欄位 T1(id,e,f,g):一些不常用欄位 T2(id,name,value): id name valu ...
  • 1. mongodb資料庫的命令 查看當前的資料庫:db 查看所有的資料庫:show dbs /show databases 切換資料庫:use db_name 刪除當前的資料庫:db.dropDatabase() 2. mongodb集合的命令 不手動創建集合: 向不存在的集合中第⼀次加⼊數據時, ...
  • 最近到了一家新公司,很多全新技術棧要理解。每天都在看各類 English Offcial Document,我的宗旨是我既然看懂了,就寫下來分享,這是第一篇。 基本需求: 1、已有 zookeeper 集群 2、kafka 搭建請務必準備三台伺服器 步驟: 1、下載所需要版本的 kafka http ...
  • 一個大的SQL語句操作,執行計劃中包含了一個merge操作,觀察到SQL長時間處於IO_COMPLETION等待狀態,如果是讀取相關的表的數據,伺服器應該全力為其服務,但是伺服器的物理IO又遠遠沒有達到瓶頸。這個IO_COMPLETION到底是在做什麼?是表的數據頁IO請求還在其他操作?如果是,跟P ...
  • MongoDB 使用過程中經常需要根據欄位的類型來查詢數據, 而MongoDB中查詢欄位類型是通過$type操作符來實現. $type使用法語: 舉個例子: 再舉個有點特殊的查詢,關於null 查詢的例子: $type 有效的類型值,如下: Type| Number |Alias| Notes |: ...
  • 大數據,是未來必然的發展趨勢,當下我國的大數據建設已經如火如荼的進行著,無論是企業,還是個人,都逐步意識到大數據學習的重要性,大數據在未來的應用前進還會更加廣泛,不少初學者開始自學大數據。 基本上剛開始學習,大家都是從看書開始的,當然如果你覺得自己看書效率太慢,就可以從網上搜集一些課程,課程質量參差 ...
  • 直接執行:sudo yum install ntp或者sudo -y install ntp ...
一周排行
    -Advertisement-
    Play Games
  • 移動開發(一):使用.NET MAUI開發第一個安卓APP 對於工作多年的C#程式員來說,近來想嘗試開發一款安卓APP,考慮了很久最終選擇使用.NET MAUI這個微軟官方的框架來嘗試體驗開發安卓APP,畢竟是使用Visual Studio開發工具,使用起來也比較的順手,結合微軟官方的教程進行了安卓 ...
  • 前言 QuestPDF 是一個開源 .NET 庫,用於生成 PDF 文檔。使用了C# Fluent API方式可簡化開發、減少錯誤並提高工作效率。利用它可以輕鬆生成 PDF 報告、發票、導出文件等。 項目介紹 QuestPDF 是一個革命性的開源 .NET 庫,它徹底改變了我們生成 PDF 文檔的方 ...
  • 項目地址 項目後端地址: https://github.com/ZyPLJ/ZYTteeHole 項目前端頁面地址: ZyPLJ/TreeHoleVue (github.com) https://github.com/ZyPLJ/TreeHoleVue 目前項目測試訪問地址: http://tree ...
  • 話不多說,直接開乾 一.下載 1.官方鏈接下載: https://www.microsoft.com/zh-cn/sql-server/sql-server-downloads 2.在下載目錄中找到下麵這個小的安裝包 SQL2022-SSEI-Dev.exe,運行開始下載SQL server; 二. ...
  • 前言 隨著物聯網(IoT)技術的迅猛發展,MQTT(消息隊列遙測傳輸)協議憑藉其輕量級和高效性,已成為眾多物聯網應用的首選通信標準。 MQTTnet 作為一個高性能的 .NET 開源庫,為 .NET 平臺上的 MQTT 客戶端與伺服器開發提供了強大的支持。 本文將全面介紹 MQTTnet 的核心功能 ...
  • Serilog支持多種接收器用於日誌存儲,增強器用於添加屬性,LogContext管理動態屬性,支持多種輸出格式包括純文本、JSON及ExpressionTemplate。還提供了自定義格式化選項,適用於不同需求。 ...
  • 目錄簡介獲取 HTML 文檔解析 HTML 文檔測試參考文章 簡介 動態內容網站使用 JavaScript 腳本動態檢索和渲染數據,爬取信息時需要模擬瀏覽器行為,否則獲取到的源碼基本是空的。 本文使用的爬取步驟如下: 使用 Selenium 獲取渲染後的 HTML 文檔 使用 HtmlAgility ...
  • 1.前言 什麼是熱更新 游戲或者軟體更新時,無需重新下載客戶端進行安裝,而是在應用程式啟動的情況下,在內部進行資源或者代碼更新 Unity目前常用熱更新解決方案 HybridCLR,Xlua,ILRuntime等 Unity目前常用資源管理解決方案 AssetBundles,Addressable, ...
  • 本文章主要是在C# ASP.NET Core Web API框架實現向手機發送驗證碼簡訊功能。這裡我選擇是一個互億無線簡訊驗證碼平臺,其實像阿裡雲,騰訊雲上面也可以。 首先我們先去 互億無線 https://www.ihuyi.com/api/sms.html 去註冊一個賬號 註冊完成賬號後,它會送 ...
  • 通過以下方式可以高效,並保證數據同步的可靠性 1.API設計 使用RESTful設計,確保API端點明確,並使用適當的HTTP方法(如POST用於創建,PUT用於更新)。 設計清晰的請求和響應模型,以確保客戶端能夠理解預期格式。 2.數據驗證 在伺服器端進行嚴格的數據驗證,確保接收到的數據符合預期格 ...