第五講 樹(下)

来源:http://www.cnblogs.com/VincentValentine/archive/2017/05/12/6847288.html
-Advertisement-
Play Games

05 樹7:堆中的路徑 Description: 將一系列給定數字插入一個初始為空的小頂堆H[]。隨後對任意給定的下標i,列印從H[i]到根結點的路徑。 Input: 每組測試第1行包含2個正整數N和M(≤1000),分別是插入元素的個數、以及需要列印的路徑條數。下一行給出區間[ 10000, 10 ...


05-樹7:堆中的路徑
Description:

將一系列給定數字插入一個初始為空的小頂堆H[]。隨後對任意給定的下標i,列印從H[i]到根結點的路徑。

Input:

每組測試第1行包含2個正整數N和M(≤1000),分別是插入元素的個數、以及需要列印的路徑條數。下一行給出區間[-10000, 10000]內的N個要被插入一個初始為空的小頂堆的整數。最後一行給出M個下標。

Output:

對輸入中給出的每個下標i,在一行中輸出從H[i]到根結點的路徑上的數據。數字間以1個空格分隔,行末不得有多餘空格。

SampleInput:

5 3
46 23 26 24 10
5 4 3

SampleOutput:

24 23 10
46 23 10
26 10

Codes:
//#define LOCAL

#include <cstdio>

#define M 1010
#define S -10010
int i, cnt, A[M] = {S};

void insert(int a) {
    for(i=++cnt; A[i/2]>a; i/=2) A[i] = A[i/2];
    A[i] = a;
}

int main()
{
    #ifdef LOCAL
        freopen("E:\\Temp\\input.txt", "r", stdin);
        freopen("E:\\Temp\\output.txt", "w", stdout);
    #endif

    int a, n, m;
    scanf("%d%d", &n, &m);

    while(n--) { scanf("%d", &a); insert(a); }
    while(m--) {
        scanf("%d", &a);
        printf("%d", A[a]); a /= 2;
        while(a) { printf(" %d", A[a]); a /= 2; } 
        printf("\n"); 
    }

    return 0;
}
05-樹8:File Transfer.
Description:

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input:

Each input file contains one test case. For each test case, the first line contains N(2, 10^4), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and N. Then in the following lines, the input is given in the format: I c1 c2 where I stands for inputting a connection between c1 and c2; or C c1 c2 where C stands for checking if it is possible to transfer files between c1 and c2; or S where S stands for stopping this case.

Output:

For each C case, print in one line the word "yes" or "no" if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line "The network is connected." if there is a path between any pair of computers; or "There are k components." where k is the number of connected components in this network.

SampleInput1:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
S

SampleOutput1:

no
no
yes
There are 2 components.

SampleInput2:

5
C 3 2
I 3 2
C 1 5
I 4 5
I 2 4
C 3 5
I 1 3
C 1 5
S

SampleOutput2:

no
no
yes
yes
The network is connected.

Codes:
//#define LOCAL

#include <cstdio>
#include <cstdlib>

int findS(int *s, int v) {
    while(s[v] >= 0) v = s[v];
    return v;
}

void unionS(int *s, int c1, int c2) {
    int r1 = findS(s, c1), r2 = findS(s, c2);
    if(s[r1] < s[r2]) { s[r1] += s[r2]; s[r2] = r1; }
    else { s[r2] += s[r1]; s[r1] = r2; }
}

int main()
{
    #ifdef LOCAL
        freopen("E:\\Temp\\input.txt", "r", stdin);
        freopen("E:\\Temp\\output.txt", "w", stdout);
    #endif

    int i, n, c1, c2, cnt = 0; char c;
    scanf("%d\n%c", &n, &c);
    
    int *s = (int*)malloc(sizeof(int)*(n+1));
    for(i=0; i<=n; ++i) s[i] = -1;
    while(c != 'S') {
        scanf("%d%d", &c1, &c2);
        if(c == 'I') unionS(s, c1, c2);
        else if(c == 'C') {
            if(findS(s, c1) == findS(s, c2)) printf("yes\n");
            else printf("no\n");
        }
        scanf("\n%c", &c);
    }

    for(i=1; i<=n; ++i) if(s[i] < 0) ++cnt;
    if(cnt == 1) printf("The network is connected.\n");
    else printf("There are %d components.\n", cnt);
    free(s);

    return 0;
}

您的分享是我們最大的動力!

-Advertisement-
Play Games
更多相關文章
  • import java.io.FileInputStream;import java.io.FileOutputStream;import java.io.IOException;import java.util.LinkedList;import java.util.List; //文件複製 // ...
  • 問題:char[]與String相比,有什麼優勝的地方? 回答: 針對安全保密高的信息,char[]比String做得更好。因為String是不可變得,即使你修改原先的變數,實際上也是在記憶體中新建一個對象,原數據還是保留在記憶體中,等待回收。而char[]中的元素是可以更改的。這就意味著,如密碼等保密 ...
  • You are given an n x n 2D matrix representing an image. Rotate the image by 90 degrees (clockwise). Follow up: Could you do this in-place? ...
  • import java.awt.Color;import java.awt.Font;import java.awt.Graphics;import java.awt.Toolkit;import java.awt.event.MouseAdapter;import java.awt.event.M ...
  • Given a collection of distinct numbers, return all possible permutations. ...
  • Python 多進程多線程原理介紹以及原創的Python多進程和多線程模板 ...
  • 創建內部類的對象可用 .this和.new來創建。 具體看代碼 在這段代碼中,我用pri的一個實例創建了一個inner類的對象b。由於非靜態內部類必須依附在外部類的實例上,所以在代碼的末尾證實通過.this返回的外部類的對象c與外部類的實例對象a是同一個對象。 在這段代碼中,我還在外部pri中創建了 ...
  • [root@ ~/learn_code/C++_learn]$ tree.├── main├── main.cpp├── test│ ├── libtest.a│ ├── makefile│ ├── test.c│ ├── test.h│ ├── test.i│ ├── test.o│ └── te ...
一周排行
    -Advertisement-
    Play Games
  • 移動開發(一):使用.NET MAUI開發第一個安卓APP 對於工作多年的C#程式員來說,近來想嘗試開發一款安卓APP,考慮了很久最終選擇使用.NET MAUI這個微軟官方的框架來嘗試體驗開發安卓APP,畢竟是使用Visual Studio開發工具,使用起來也比較的順手,結合微軟官方的教程進行了安卓 ...
  • 前言 QuestPDF 是一個開源 .NET 庫,用於生成 PDF 文檔。使用了C# Fluent API方式可簡化開發、減少錯誤並提高工作效率。利用它可以輕鬆生成 PDF 報告、發票、導出文件等。 項目介紹 QuestPDF 是一個革命性的開源 .NET 庫,它徹底改變了我們生成 PDF 文檔的方 ...
  • 項目地址 項目後端地址: https://github.com/ZyPLJ/ZYTteeHole 項目前端頁面地址: ZyPLJ/TreeHoleVue (github.com) https://github.com/ZyPLJ/TreeHoleVue 目前項目測試訪問地址: http://tree ...
  • 話不多說,直接開乾 一.下載 1.官方鏈接下載: https://www.microsoft.com/zh-cn/sql-server/sql-server-downloads 2.在下載目錄中找到下麵這個小的安裝包 SQL2022-SSEI-Dev.exe,運行開始下載SQL server; 二. ...
  • 前言 隨著物聯網(IoT)技術的迅猛發展,MQTT(消息隊列遙測傳輸)協議憑藉其輕量級和高效性,已成為眾多物聯網應用的首選通信標準。 MQTTnet 作為一個高性能的 .NET 開源庫,為 .NET 平臺上的 MQTT 客戶端與伺服器開發提供了強大的支持。 本文將全面介紹 MQTTnet 的核心功能 ...
  • Serilog支持多種接收器用於日誌存儲,增強器用於添加屬性,LogContext管理動態屬性,支持多種輸出格式包括純文本、JSON及ExpressionTemplate。還提供了自定義格式化選項,適用於不同需求。 ...
  • 目錄簡介獲取 HTML 文檔解析 HTML 文檔測試參考文章 簡介 動態內容網站使用 JavaScript 腳本動態檢索和渲染數據,爬取信息時需要模擬瀏覽器行為,否則獲取到的源碼基本是空的。 本文使用的爬取步驟如下: 使用 Selenium 獲取渲染後的 HTML 文檔 使用 HtmlAgility ...
  • 1.前言 什麼是熱更新 游戲或者軟體更新時,無需重新下載客戶端進行安裝,而是在應用程式啟動的情況下,在內部進行資源或者代碼更新 Unity目前常用熱更新解決方案 HybridCLR,Xlua,ILRuntime等 Unity目前常用資源管理解決方案 AssetBundles,Addressable, ...
  • 本文章主要是在C# ASP.NET Core Web API框架實現向手機發送驗證碼簡訊功能。這裡我選擇是一個互億無線簡訊驗證碼平臺,其實像阿裡雲,騰訊雲上面也可以。 首先我們先去 互億無線 https://www.ihuyi.com/api/sms.html 去註冊一個賬號 註冊完成賬號後,它會送 ...
  • 通過以下方式可以高效,並保證數據同步的可靠性 1.API設計 使用RESTful設計,確保API端點明確,並使用適當的HTTP方法(如POST用於創建,PUT用於更新)。 設計清晰的請求和響應模型,以確保客戶端能夠理解預期格式。 2.數據驗證 在伺服器端進行嚴格的數據驗證,確保接收到的數據符合預期格 ...