【ZOJ 2966】Build The Electric System(最小生成樹 Kruskal )

来源:https://www.cnblogs.com/kannyi/archive/2018/03/22/8627371.html
-Advertisement-
Play Games

Description In last winter, there was a big snow storm in South China. The electric system was damaged seriously. Lots of power lines were broken and ...


Description

In last winter, there was a big snow storm in South China. The electric system was damaged seriously. Lots of power lines were broken and lots of villages lost contact with the main power grid. The government wants to reconstruct the electric system as soon as possible. So, as a professional programmer, you are asked to write a program to calculate the minimum cost to reconstruct the power lines to make sure there's at least one way between every two villages.

Input

Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 50) which is the number of test cases. And it will be followed by T consecutive test cases.

In each test case, the first line contains two positive integers N and E (2 <= N <= 500, N <= E <= N * (N - 1) / 2), representing the number of the villages and the number of the original power lines between villages. There follow E lines, and each of them contains three integers, ABK (0 <= AB < N, 0 <= K < 1000). A and B respectively means the index of the starting village and ending village of the power line. If K is 0, it means this line still works fine after the snow storm. If K is a positive integer, it means this line will cost Kto reconstruct. There will be at most one line between any two villages, and there will not be any line from one village to itself.

Output

For each test case in the input, there's only one line that contains the minimum cost to recover the electric system to make sure that there's at least one way between every two villages.

Sample Input

1
3 3
0 1 5
0 2 0
1 2 9

Sample Output

5

題意

給出一個無向邊帶權圖,輸出最小生成樹

#include<iostream>
#include<algorithm>
using namespace std;
int p[10005],n,e;
struct edge
{
    int x,y,w;
}a[10005];
int cmp(edge a,edge b)
{
    return a.w<b.w;
}
int find(int r)
{
    if(p[r]!=r)
    p[r]=find(p[r]);
    return p[r];
}
int k()
{
    sort(a,a+e,cmp);              //一定要以邊edge排序啊!!!
    int ans=0,i;
    for(i=0;i<e;i++)
    {
        int fx=find(a[i].x),fy=find(a[i].y);
        if(fx!=fy)
        {
            p[fx]=fy;
            ans+=a[i].w;
        } 
    }
    return ans;
}
int main()  
{  
    int t,i;
    cin>>t;
    while(t--)
    {
        cin>>n>>e;
        for(i=0;i<=n;i++)
            p[i]=i;
        for(i=0;i<e;i++)
            scanf("%d%d%d",&a[i].x,&a[i].y,&a[i].w);
        printf("%d\n",k());
    } 
    return 0;
}

您的分享是我們最大的動力!

-Advertisement-
Play Games
更多相關文章
  • 這兩天看了《移山之道:VSTS軟體開髮指南》,對團隊軟體開發又有了新的認識。也許對於我們這些軟體開發的新手來說,最重要的是具體技術與應用框架,但讀了這本書後我感覺到,實際團隊項目中工具的使用是次要的,更重要的在於對人員的控制,如何高效得讓一個團隊各司其職、彼此之間在充分信息交流的基礎上協同工作才是一 ...
  • 目的描述:全新的騰訊雲Linux伺服器,系統是ubuntu 16.04。需要在上面安裝mysql資料庫。 使用XShell遠程登錄,在終端視窗中使用sudo apt-get 指令線上安裝mysql。 在安裝MySql之前先執行更新指令: 效果圖如下: 接著執行安裝MySql指令: 這時候系統會去下載 ...
  • 一、前言 最近有點想弄一個站內搜索的功能,之前學過了Lucene,後來又聽過Solr這個名詞。接著在瞭解全文搜索的時候就發現了Elasticsearch這個,他也是以Lucene為基礎的。 我去搜了幾篇Elasticsearch教程,發現很多都是基於linux的,但我linux耍得並不熟,很少用。僅 ...
  • Django 千鋒培訓讀書筆記 https://www.bilibili.com/video/av17879644/?p=1 切換到創建項目的目錄 cd C:\Users\admin\Desktop\DjangoProject 創建名為project的項目命令 django-admin startp... ...
  • L2-006. 樹的遍歷 時間限制 記憶體限制 代碼長度限制 判題程式 作者 400 ms 65536 kB 8000 B Standard 陳越 給定一棵二叉樹的後序遍歷和中序遍歷,請你輸出其層序遍歷的序列。這裡假設鍵值都是互不相等的正整數。 時間限制 記憶體限制 代碼長度限制 判題程式 作者 400 ...
  • python數據類型、數字類型、int、float、math ...
  • selenium安裝 selenium操作瀏覽器原理 早期selenium 1.0 用的selenium RC, 後來selenum2集合了selenium1.0 + webdriver,selenium RC被webdriver替換。通過webdriver,測試腳本(例如python)可以方便的通 ...
  • 事務管理對於企業應用來說是至關重要的,當出現異常情況時,它也可以保證數據的一致性。 Spring事務管理的兩種方式 spring支持編程式事務管理和聲明式事務管理兩種方式。 編程式事務 使用TransactionTemplate或者直接使用底層的PlatformTransactionManager。 ...
一周排行
    -Advertisement-
    Play Games
  • 移動開發(一):使用.NET MAUI開發第一個安卓APP 對於工作多年的C#程式員來說,近來想嘗試開發一款安卓APP,考慮了很久最終選擇使用.NET MAUI這個微軟官方的框架來嘗試體驗開發安卓APP,畢竟是使用Visual Studio開發工具,使用起來也比較的順手,結合微軟官方的教程進行了安卓 ...
  • 前言 QuestPDF 是一個開源 .NET 庫,用於生成 PDF 文檔。使用了C# Fluent API方式可簡化開發、減少錯誤並提高工作效率。利用它可以輕鬆生成 PDF 報告、發票、導出文件等。 項目介紹 QuestPDF 是一個革命性的開源 .NET 庫,它徹底改變了我們生成 PDF 文檔的方 ...
  • 項目地址 項目後端地址: https://github.com/ZyPLJ/ZYTteeHole 項目前端頁面地址: ZyPLJ/TreeHoleVue (github.com) https://github.com/ZyPLJ/TreeHoleVue 目前項目測試訪問地址: http://tree ...
  • 話不多說,直接開乾 一.下載 1.官方鏈接下載: https://www.microsoft.com/zh-cn/sql-server/sql-server-downloads 2.在下載目錄中找到下麵這個小的安裝包 SQL2022-SSEI-Dev.exe,運行開始下載SQL server; 二. ...
  • 前言 隨著物聯網(IoT)技術的迅猛發展,MQTT(消息隊列遙測傳輸)協議憑藉其輕量級和高效性,已成為眾多物聯網應用的首選通信標準。 MQTTnet 作為一個高性能的 .NET 開源庫,為 .NET 平臺上的 MQTT 客戶端與伺服器開發提供了強大的支持。 本文將全面介紹 MQTTnet 的核心功能 ...
  • Serilog支持多種接收器用於日誌存儲,增強器用於添加屬性,LogContext管理動態屬性,支持多種輸出格式包括純文本、JSON及ExpressionTemplate。還提供了自定義格式化選項,適用於不同需求。 ...
  • 目錄簡介獲取 HTML 文檔解析 HTML 文檔測試參考文章 簡介 動態內容網站使用 JavaScript 腳本動態檢索和渲染數據,爬取信息時需要模擬瀏覽器行為,否則獲取到的源碼基本是空的。 本文使用的爬取步驟如下: 使用 Selenium 獲取渲染後的 HTML 文檔 使用 HtmlAgility ...
  • 1.前言 什麼是熱更新 游戲或者軟體更新時,無需重新下載客戶端進行安裝,而是在應用程式啟動的情況下,在內部進行資源或者代碼更新 Unity目前常用熱更新解決方案 HybridCLR,Xlua,ILRuntime等 Unity目前常用資源管理解決方案 AssetBundles,Addressable, ...
  • 本文章主要是在C# ASP.NET Core Web API框架實現向手機發送驗證碼簡訊功能。這裡我選擇是一個互億無線簡訊驗證碼平臺,其實像阿裡雲,騰訊雲上面也可以。 首先我們先去 互億無線 https://www.ihuyi.com/api/sms.html 去註冊一個賬號 註冊完成賬號後,它會送 ...
  • 通過以下方式可以高效,並保證數據同步的可靠性 1.API設計 使用RESTful設計,確保API端點明確,並使用適當的HTTP方法(如POST用於創建,PUT用於更新)。 設計清晰的請求和響應模型,以確保客戶端能夠理解預期格式。 2.數據驗證 在伺服器端進行嚴格的數據驗證,確保接收到的數據符合預期格 ...