poj_2689_Prime Distance

来源:http://www.cnblogs.com/ygtzds/archive/2017/11/22/7881590.html
-Advertisement-
Play Games

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians ...


The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.


主要思想是偏移數組,區間素數打表。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
typedef long long LL;
#include<algorithm>
using namespace std;
#define N 1000010
int notprime[N];
int prime[N];
int prime2[N];
bool vis[N];
bool val[N];
int pn=0;

void getPrime()
{
    memset(prime,0,sizeof(prime));
    for(int i=2;i<=N;i++)
    {
        if(!prime[i])prime[++prime[0]]=i;
        for(int j=1;j<=prime[0]&&prime[j]<=N/i;j++)
        {
            prime[prime[j]*i]=1;
            if(i%prime[j]==0)break;
        }
    }
}
void getPrime2(int L,int R)
{
    memset(notprime,false,sizeof(notprime));
    if(L<2)L=2;
    for(int i=1;i<=prime[0]&&(long long)prime[i]*prime[i]<=R;i++)
    {
        int s=L/prime[i]+(L%prime[i]>0);
        if(s==1)s=2;
        for(int j=s;(long long)j*prime[i]<=R;j++)
            if((long long)j*prime[i]>=L)
                notprime[j*prime[i]-L]=true;
    }
    prime2[0]=0;
    for(int i=0;i<=R-L;i++)
        if(!notprime[i])
            prime2[++prime2[0]]=i+L;
}

int main()
{
    getPrime();
    LL m,t,h;
    int l,r;
    while(~scanf("%d%d",&l,&r))
    {
        int sh1=0,sh2=1000000,lo1=0,lo2=0;
        getPrime2(l,r);
        if(prime2[0]<2)
        {
            puts("There are no adjacent primes.");
            continue;
        }
        for(int i=1;i<prime2[0];i++)
        {
            if(sh2-sh1>prime2[i+1]-prime2[i])
            {
                sh1=prime2[i];
                sh2=prime2[i+1];
            }
            if(lo2-lo1<prime2[i+1]-prime2[i])
            {
                lo1=prime2[i];
                lo2=prime2[i+1];
            }
        }
        printf("%d,%d are closest, %d,%d are most distant.\n",sh1,sh2,lo1,lo2);
    }
}

  


您的分享是我們最大的動力!

-Advertisement-
Play Games
更多相關文章
  • substr(string,start,length) 參數:1,string 即你要截取的字元串2,start 即要截取的開始位置(0表示從從前往後數 第一個字元開始,負數表示從從後往前數) eg:start=1,表示從從前往後開始的第二個數開始截取,start=-1,表示從從後往前開始的第一(是 ...
  • 我學習SSE指令的初衷就是為了實現RGB<->RGBA, YUV<->RGBA、RGB,這些轉換的指令優化。 在學習指令優化的過程中總是會看到SIMD(Single Instructions Multi Data), 單指令多數據:在一個指令周期內使用一條指令處理多個數據。這是Intel早期開發MM ...
  • (1)如果只是看i++和++i,這兩個是等價的,都等同於i=i+1,都是變數自身加1。 (2)在一般情況下,它們都是跟賦值聯繫在一起。 比如:int a; a=i++;//將i的值賦值給a,即a=i;然後再執行i=i+1;也就是【a=i++;】與【a=i; i=i+1;】等價 a=++i;//將i+ ...
  • pandas可以讀寫如下格式的數據類型: 具體詳見:http://pandas.pydata.org/pandas docs/version/0.20/io.html 讀取csv文件 我們準備了一個csv文件,格式類似為: 要讀取此csv文件,方法為: 輸出為: 這裡我第一次嘗試運行時,由於沒有設置 ...
  • java 使用metadata-extractor 旋轉圖片 ...
  • 在事件驅動的應用中利用隊列來處理事件是一種常見的方法。 事件驅動的應用主要遵循實時事件發生的順序來執行。 例如,在java或windows中開發圖形用戶界面,應用程式的行為主要取決於鍵盤操作、滑鼠點擊等一些由用戶觸發的事件。其他一些數據驅動型的例子還包含飛機或工廠設備中的控制系統等。 在很多事件驅動 ...
  • [Python]嵌套迴圈nested loop-練習題,嵌套迴圈一向是新手的難點,所以作為新手,自己找了些練習題,供自己和大家練習使用。 ...
  • https://www.cnblogs.com/jecyhw/p/5504855.htmlhttp://blog.csdn.net/god_for/article/details/50500342 mkdir /data/php7 ./configure --prefix=/data/php7 \ ...
一周排行
    -Advertisement-
    Play Games
  • 移動開發(一):使用.NET MAUI開發第一個安卓APP 對於工作多年的C#程式員來說,近來想嘗試開發一款安卓APP,考慮了很久最終選擇使用.NET MAUI這個微軟官方的框架來嘗試體驗開發安卓APP,畢竟是使用Visual Studio開發工具,使用起來也比較的順手,結合微軟官方的教程進行了安卓 ...
  • 前言 QuestPDF 是一個開源 .NET 庫,用於生成 PDF 文檔。使用了C# Fluent API方式可簡化開發、減少錯誤並提高工作效率。利用它可以輕鬆生成 PDF 報告、發票、導出文件等。 項目介紹 QuestPDF 是一個革命性的開源 .NET 庫,它徹底改變了我們生成 PDF 文檔的方 ...
  • 項目地址 項目後端地址: https://github.com/ZyPLJ/ZYTteeHole 項目前端頁面地址: ZyPLJ/TreeHoleVue (github.com) https://github.com/ZyPLJ/TreeHoleVue 目前項目測試訪問地址: http://tree ...
  • 話不多說,直接開乾 一.下載 1.官方鏈接下載: https://www.microsoft.com/zh-cn/sql-server/sql-server-downloads 2.在下載目錄中找到下麵這個小的安裝包 SQL2022-SSEI-Dev.exe,運行開始下載SQL server; 二. ...
  • 前言 隨著物聯網(IoT)技術的迅猛發展,MQTT(消息隊列遙測傳輸)協議憑藉其輕量級和高效性,已成為眾多物聯網應用的首選通信標準。 MQTTnet 作為一個高性能的 .NET 開源庫,為 .NET 平臺上的 MQTT 客戶端與伺服器開發提供了強大的支持。 本文將全面介紹 MQTTnet 的核心功能 ...
  • Serilog支持多種接收器用於日誌存儲,增強器用於添加屬性,LogContext管理動態屬性,支持多種輸出格式包括純文本、JSON及ExpressionTemplate。還提供了自定義格式化選項,適用於不同需求。 ...
  • 目錄簡介獲取 HTML 文檔解析 HTML 文檔測試參考文章 簡介 動態內容網站使用 JavaScript 腳本動態檢索和渲染數據,爬取信息時需要模擬瀏覽器行為,否則獲取到的源碼基本是空的。 本文使用的爬取步驟如下: 使用 Selenium 獲取渲染後的 HTML 文檔 使用 HtmlAgility ...
  • 1.前言 什麼是熱更新 游戲或者軟體更新時,無需重新下載客戶端進行安裝,而是在應用程式啟動的情況下,在內部進行資源或者代碼更新 Unity目前常用熱更新解決方案 HybridCLR,Xlua,ILRuntime等 Unity目前常用資源管理解決方案 AssetBundles,Addressable, ...
  • 本文章主要是在C# ASP.NET Core Web API框架實現向手機發送驗證碼簡訊功能。這裡我選擇是一個互億無線簡訊驗證碼平臺,其實像阿裡雲,騰訊雲上面也可以。 首先我們先去 互億無線 https://www.ihuyi.com/api/sms.html 去註冊一個賬號 註冊完成賬號後,它會送 ...
  • 通過以下方式可以高效,並保證數據同步的可靠性 1.API設計 使用RESTful設計,確保API端點明確,並使用適當的HTTP方法(如POST用於創建,PUT用於更新)。 設計清晰的請求和響應模型,以確保客戶端能夠理解預期格式。 2.數據驗證 在伺服器端進行嚴格的數據驗證,確保接收到的數據符合預期格 ...