HDU 5113--Black And White(搜索+剪枝)

来源:http://www.cnblogs.com/chen9510/archive/2017/06/25/7077871.html
-Advertisement-
Play Games

題目鏈接 Problem Description In mathematics, the four color theorem, or the four color map theorem, states that, given any separation of a plane into cont ...


題目鏈接

 

Problem Description In mathematics, the four color theorem, or the four color map theorem, states that, given any separation of a plane into contiguous regions, producing a figure called a map, no more than four colors are required to color the regions of the map so that no two adjacent regions have the same color.
— Wikipedia, the free encyclopedia

In this problem, you have to solve the 4-color problem. Hey, I’m just joking.

You are asked to solve a similar problem:

Color an N × M chessboard with K colors numbered from 1 to K such that no two adjacent cells have the same color (two cells are adjacent if they share an edge). The i-th color should be used in exactly ci cells.

Matt hopes you can tell him a possible coloring.  

 

Input The first line contains only one integer T (1 ≤ T ≤ 5000), which indicates the number of test cases.

For each test case, the first line contains three integers: N, M, K (0 < N, M ≤ 5, 0 < K ≤ N × M ).

The second line contains K integers ci (ci > 0), denoting the number of cells where the i-th color should be used.

It’s guaranteed that c1 + c2 + · · · + cK = N × M .  

 

Output For each test case, the first line contains “Case #x:”, where x is the case number (starting from 1). 

In the second line, output “NO” if there is no coloring satisfying the requirements. Otherwise, output “YES” in one line. Each of the following N lines contains M numbers seperated by single whitespace, denoting the color of the cells.

If there are multiple solutions, output any of them.  

 

Sample Input 4 1 5 2 4 1 3 3 4 1 2 2 4 2 3 3 2 2 2 3 2 3 2 2 2  

 

Sample Output Case #1: NO Case #2: YES 4 3 4 2 1 2 4 3 4 Case #3: YES 1 2 3 2 3 1 Case #4: YES 1 2 2 3 3 1

 

題意:有一個N*M的方格板,現在要在上面的每個方格上塗顏色,有K種顏色,每種顏色分別塗c[1]次、c[2]次……c[K]次,c[1]+c[2]+……+c[K]=N*M

          要求每個方格的顏色與其上下左右均不同,如果可以輸出YES,並且輸出其中的一種塗法,如果不行,輸出NO;

思路:暴力搜索,但是這樣會超時,可以在搜索中加入剪枝:對於剩餘的方格數res,以及當前剩餘的顏色可塗數必須滿足(res+1)/2>=c[i]  

          否則在當前情況下繼續向下搜得不到正確塗法;

 

代碼如下:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
int N,K,M;
int c[30];
int mp[10][10];

int check(int x,int y,int k)
{
    int f=1;
    if(mp[x-1][y]==k) f=0;
    if(mp[x][y-1]==k) f=0;
    return f;
}

int cal(int x,int y)
{
    if(x>N) return 1;
    int res=(N-x)*M+M-y+2; ///剩餘方格數+1 ;
    for(int i=1;i<=K;i++) if(res/2<c[i]) return 0; ///剪枝,某種顏色剩餘方格數>(剩餘方格數+1)/2 肯定不對;
    for(int i=1;i<=K;i++)
    {
        int f=0;
        if(c[i]&&check(x,y,i)){
            mp[x][y]=i; c[i]--;
            if(y==M)  f=cal(x+1,1);
            else      f=cal(x,y+1);
            c[i]++;
        }
        if(f) return 1;
    }
    return 0;
}

int main()
{
    int T,Case=1;
    cin>>T;
    while(T--)
    {
       scanf("%d%d%d",&N,&M,&K);
       for(int i=1;i<=K;i++) scanf("%d",&c[i]);
       printf("Case #%d:\n",Case++);

       if(!cal(1,1)) { puts("NO"); continue; }
       puts("YES");
       for(int i=1;i<=N;i++)
       for(int j=1;j<=M;j++)
         printf("%d%c",mp[i][j],(j==M)?'\n':' ');
    }
    return 0;
}

 


您的分享是我們最大的動力!

-Advertisement-
Play Games
更多相關文章
  • 在編寫穩定可靠的軟體服務時經常用到輸出堆棧信息,以便用戶/開發者獲取準確的運行信息。常用在日誌輸出,錯誤報告,異常檢測。本文介紹Linux與Windows下用C++獲取堆棧信息的方法。 ...
  • JSON-lib包(最關鍵的兩個類分別是JSONObject和JSONArray)完成對json的構造和一些基本方法的使用。 二者區別: ①JSONObject構造的字元串是鍵值對形式(key:value),多個鍵值對間以英文逗號連接; ②JSONArray構造的字元串是數組形式([array1,a ...
  • 反射的基本概述 一個class文件被載入到記憶體的時候,JVM就會經行解剖,把這個class文件的所有成員全部解剖出來,然後JVM會創建一個Class對象,把這些成員信息全部都封裝起來,所謂反射就是指:我們獲取到這個Class對象,就相當於獲取到了該類的所有成員信息,我們就能操又該類的所有成員. Ja ...
  • 無意間碰到的一個大神整理的Python學習思維導圖,感覺對初學者理清學習思路大有裨益,非常感謝他的分享。 詳情見:https://woaielf.github.io/2017/06/13/python3-all/ 14 張思維導圖 基礎知識 數據類型 序列 字元串 列表 & 元組 字典 & 集合 條 ...
  • /* 工作單元 這個模式涉及到了領域模型、數據映射器和標識映射,這裡就統一進行整理和回顧了。 $venue = new \woo\domain\Venue(null,"The Green Tree"); \woo\domain\ObjectWatcher::instance()->performOp... ...
  • 分享 知識要點:lubridate包拆解時間 | POSIXlt利用決策樹分類,利用隨機森林預測利用對數進行fit,和exp函數還原 訓練集來自Kaggle華盛頓自行車共用計劃中的自行車租賃數據,分析共用自行車與天氣、時間等關係。數據集共11個變數,10000多行數據。https://www.kag ...
  • 【數組基礎】【數組遍歷】【超全局數組】【數組功能】【數組函數】 ...
  •  也不知道這個標題中的原則一詞用的對不對,我姑且叫他原則吧。對於寫代碼的我們來說,其實我後面會叫他規範,但是想了想,對於其他方面來說,又或許是原則,好啦,不糾結,直接進入正題。  來新公司一個多月了,從我剛到公司那天剛好是一個迭代的開始,直到昨天,後臺版本已經同步到公網,APP因 ...
一周排行
    -Advertisement-
    Play Games
  • 移動開發(一):使用.NET MAUI開發第一個安卓APP 對於工作多年的C#程式員來說,近來想嘗試開發一款安卓APP,考慮了很久最終選擇使用.NET MAUI這個微軟官方的框架來嘗試體驗開發安卓APP,畢竟是使用Visual Studio開發工具,使用起來也比較的順手,結合微軟官方的教程進行了安卓 ...
  • 前言 QuestPDF 是一個開源 .NET 庫,用於生成 PDF 文檔。使用了C# Fluent API方式可簡化開發、減少錯誤並提高工作效率。利用它可以輕鬆生成 PDF 報告、發票、導出文件等。 項目介紹 QuestPDF 是一個革命性的開源 .NET 庫,它徹底改變了我們生成 PDF 文檔的方 ...
  • 項目地址 項目後端地址: https://github.com/ZyPLJ/ZYTteeHole 項目前端頁面地址: ZyPLJ/TreeHoleVue (github.com) https://github.com/ZyPLJ/TreeHoleVue 目前項目測試訪問地址: http://tree ...
  • 話不多說,直接開乾 一.下載 1.官方鏈接下載: https://www.microsoft.com/zh-cn/sql-server/sql-server-downloads 2.在下載目錄中找到下麵這個小的安裝包 SQL2022-SSEI-Dev.exe,運行開始下載SQL server; 二. ...
  • 前言 隨著物聯網(IoT)技術的迅猛發展,MQTT(消息隊列遙測傳輸)協議憑藉其輕量級和高效性,已成為眾多物聯網應用的首選通信標準。 MQTTnet 作為一個高性能的 .NET 開源庫,為 .NET 平臺上的 MQTT 客戶端與伺服器開發提供了強大的支持。 本文將全面介紹 MQTTnet 的核心功能 ...
  • Serilog支持多種接收器用於日誌存儲,增強器用於添加屬性,LogContext管理動態屬性,支持多種輸出格式包括純文本、JSON及ExpressionTemplate。還提供了自定義格式化選項,適用於不同需求。 ...
  • 目錄簡介獲取 HTML 文檔解析 HTML 文檔測試參考文章 簡介 動態內容網站使用 JavaScript 腳本動態檢索和渲染數據,爬取信息時需要模擬瀏覽器行為,否則獲取到的源碼基本是空的。 本文使用的爬取步驟如下: 使用 Selenium 獲取渲染後的 HTML 文檔 使用 HtmlAgility ...
  • 1.前言 什麼是熱更新 游戲或者軟體更新時,無需重新下載客戶端進行安裝,而是在應用程式啟動的情況下,在內部進行資源或者代碼更新 Unity目前常用熱更新解決方案 HybridCLR,Xlua,ILRuntime等 Unity目前常用資源管理解決方案 AssetBundles,Addressable, ...
  • 本文章主要是在C# ASP.NET Core Web API框架實現向手機發送驗證碼簡訊功能。這裡我選擇是一個互億無線簡訊驗證碼平臺,其實像阿裡雲,騰訊雲上面也可以。 首先我們先去 互億無線 https://www.ihuyi.com/api/sms.html 去註冊一個賬號 註冊完成賬號後,它會送 ...
  • 通過以下方式可以高效,並保證數據同步的可靠性 1.API設計 使用RESTful設計,確保API端點明確,並使用適當的HTTP方法(如POST用於創建,PUT用於更新)。 設計清晰的請求和響應模型,以確保客戶端能夠理解預期格式。 2.數據驗證 在伺服器端進行嚴格的數據驗證,確保接收到的數據符合預期格 ...