HDU 5091---Beam Cannon(線段樹+掃描線)

来源:http://www.cnblogs.com/chen9510/archive/2016/10/12/5953846.html
-Advertisement-
Play Games

題目鏈接 http://acm.hdu.edu.cn/showproblem.php?pid=5091 Problem Description Recently, the γ galaxies broke out Star Wars. Each planet is warring for resou ...


題目鏈接

http://acm.hdu.edu.cn/showproblem.php?pid=5091

 

Problem Description Recently, the γ galaxies broke out Star Wars. Each planet is warring for resources. In the Star Wars, Planet X is under attack by other planets. Now, a large wave of enemy spaceships is approaching. There is a very large Beam Cannon on the Planet X, and it is very powerful, which can destroy all the spaceships in its attack range in a second. However, it takes a long time to fill the energy of the Beam Cannon after each shot. So, you should make sure each shot can destroy the enemy spaceships as many as possible.

To simplify the problem, the Beam Cannon can shot at any area in the space, and the attack area is rectangular. The rectangle parallels to the coordinate axes and cannot rotate. It can only move horizontally or vertically. The enemy spaceship in the space can be considered as a point projected to the attack plane. If the point is in the rectangular attack area of the Beam Cannon(including border), the spaceship will be destroyed.   Input Input contains multiple test cases. Each test case contains three integers N(1<=N<=10000, the number of enemy spaceships), W(1<=W<=40000, the width of the Beam Cannon’s attack area), H(1<=H<=40000, the height of the Beam Cannon’s attack area) in the first line, and then N lines follow. Each line contains two integers x,y (-20000<=x,y<=20000, the coordinates of an enemy spaceship). 

A test case starting with a negative integer terminates the input and this test case should not to be processed.   Output Output the maximum number of enemy spaceships the Beam Cannon can destroy in a single shot for each case.   Sample Input 2 3 4 0 1 1 0 3 1 1 -1 0 0 1 1 0 -1   Sample Output 2 2   Source 2014上海全國邀請賽——題目重現(感謝上海大學提供題目)  

 

Recommend hujie   |   We have carefully selected several similar problems for you:  5932 5931 5930 5929 5928    題意:在平面上有n個點,現在有一個平行於坐標軸的矩形,寬為w 高為h,可以上下左右移動,但不能旋轉,求這個矩形最多能夠圍住多少點?   思路:將輸入的n個點按照橫坐標從小到大排序,為了計算方便,在輸入的時候可以對每個點記錄一個標記點(打標記),如果輸入的點是  node[i].x=x  node[i].y=y  node[i].v=1  那麼 加一個標記點node[i+1].x=x+w  node[i+1].y=y  node[i+1].v= -1  這樣對排序後的2*n個點進行計算時,只會有長為w範圍的點會被計算,走出w長度範圍的點會在計算node[i+1].v=-1 時清理掉。 那麼現在考慮的點都在長為w的範圍內,現在只需要考慮高了,可以用線段樹計算對當前點node[i] 把node[i].y~node[i].y+h的區間長度都加上node[i].v  那麼線段樹求得的最大值就是當前區間點的值了, 為什麼是這樣呢? 因為考慮的點都在長為w範圍里,所以只需要考慮y值,所以可以轉換為這些點在一條直線上,求長為h的線段能覆蓋最多的點數,考慮線段的上端點的位置,那麼一個點對上端點的貢獻為y~y+h 範圍,端點的值就是這條線段的覆蓋值;   代碼如下:
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
using namespace std;
typedef long long LL;
const int N=1e4+5;
int n,w,h;
struct Node
{
    int x,y,v;
}node[2*N];
struct TNode
{
    int f;
    int m;
}tr[16*N];

bool cmp(const Node s1,const Node s2)
{
    if(s1.x==s2.x) return s1.v>s2.v;
    return s1.x<s2.x;
}
void build(int l,int r,int i)
{
    tr[i].f=0; tr[i].m=0;
    if(l==r) return ;
    int mid=(l+r)>>1;
    build(l,mid,i<<1);
    build(mid+1,r,i<<1|1);
}
void pushdown(int i)
{
    tr[i<<1].f+=tr[i].f;
    tr[i<<1|1].f+=tr[i].f;
    tr[i<<1].m+=tr[i].f;
    tr[i<<1|1].m+=tr[i].f;
    tr[i].f=0;
}
void update(int l,int r,int i,int t)
{
    if(l>=node[t].y&&r<=node[t].y+h)
    {
        tr[i].f+=node[t].v;
        tr[i].m+=node[t].v;
        return ;
    }
    if(tr[i].f!=0)  pushdown(i);
    int mid=(l+r)>>1;
    if(node[t].y<=mid)  update(l,mid,i<<1,t);
    if(node[t].y+h>mid) update(mid+1,r,(i<<1|1),t);
    tr[i].m=max(tr[i<<1].m,tr[i<<1|1].m);
}
int main()
{
    while(scanf("%d",&n)&&n>0)
    {
        scanf("%d%d",&w,&h);
        for(int i=1;i<=n;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            node[2*i-1].x=x;
            node[2*i-1].y=y+2*N;
            node[2*i-1].v=1;
            node[2*i].x=x+w;
            node[2*i].y=y+2*N;
            node[2*i].v=-1;
        }
        sort(node+1,node+2*n+1,cmp);
        build(1,4*N,1);
        int sum=0;
        for(int i=1;i<=2*n;i++)
        {
            update(1,4*N,1,i);
            sum=max(sum,tr[1].m);
        }
        printf("%d\n",sum);
    }
    return 0;
}

 


您的分享是我們最大的動力!

-Advertisement-
Play Games
更多相關文章
  • 絕對佈局Absolute 通過放大或縮小界面的時候,組件大小和位置不會發生變化 浮動佈局FlowLayout 調整應用程式視窗的大小時,組件將立刻重新排列 邊界佈局Border Layout 該位置有5個方位:東、南、西、北、中 網格佈局Grid Layout 如需要將大量組件按規律排列,那麼網格布 ...
  • 最近手頭的工作不太繁重,自己試著倒騰了一套用開源框架組建的 JavaWeb 後端解決方案。 感覺還不錯的樣子,但實踐和項目實戰還是有很大的落差,這裡只做拋磚引玉之用。 項目 git 地址:https://git.oschina.net/LanboEx/sdh.git 大體採用的開源項目有:Sprin ...
  • 在使用R的時候會發現R對CPU的利用率並不是很高,反正當我在使用R的時候,無論R做何種運算R的CPU利用率都只有百分子幾,這就導致一旦計算量大的時候計算時間非常長,會給人一種錯覺(R真的在計算嗎?會不會我的程式死掉了?)。今天,我看到了一篇博客介紹的方法,迫不及待的嘗試了一下,只能說:太牛逼了!下麵 ...
  • 當滑鼠點擊和放開時發生動作事件; 方法摘要: actionPerformed(ActionEvent e) 發生操作時調用。 列: public class shijian extends Frame{ public static void main(String[] args) { Frame f ...
  • 問題:從 XE4 以來,Firemonkey 曲線繪圖在移動平臺不平滑的問題一直令人詬病,提交到官方的 QC 也是族繁不及備載,官方似乎有意的避開這個問題,遲遲沒有修正。 適用版本:XE4 ~ Berlin 10.1 update 1 (查過官方源碼從 XE4 開始有 FMX.StrokeBuild ...
  • re 正則表達式操作 本模塊提供了類似於Perl的正則表達式匹配操作。要匹配的模式和字元串可以是Unicode字元串以及8位字元串。 正則表達式使用反斜杠字元('\')來表示特殊的形式或者來允許使用特殊的字元而不要啟用它們特殊的含義。這與字元串字面值中相同目的的相同字元的用法衝突;例如,要匹配一個反 ...
  • 作為一個學習java的人,首先我們要瞭解java是幹嘛的,java能做什麼,以及java的歷史背景,只有當我們瞭解了java這些基礎,我們學習java才能事倍功半。 Java的歷史背景 Java是由Sun Microsystems公司推出的Java面向對象程式設計語言(以下簡稱Java語言)和Jav ...
  • 一個C程式是由一個或者多個函數組成,並必須只有一個main()函數。我建議不要使用void main的形式,同建議用 int main 然後return 0;的形式,至於為什麼要這樣做,我也不知道。 一個文件內、一個函數內、一個控制語句內、一對花括弧內,都可以稱為一個代碼塊。 聲明與定義 int n ...
一周排行
    -Advertisement-
    Play Games
  • 移動開發(一):使用.NET MAUI開發第一個安卓APP 對於工作多年的C#程式員來說,近來想嘗試開發一款安卓APP,考慮了很久最終選擇使用.NET MAUI這個微軟官方的框架來嘗試體驗開發安卓APP,畢竟是使用Visual Studio開發工具,使用起來也比較的順手,結合微軟官方的教程進行了安卓 ...
  • 前言 QuestPDF 是一個開源 .NET 庫,用於生成 PDF 文檔。使用了C# Fluent API方式可簡化開發、減少錯誤並提高工作效率。利用它可以輕鬆生成 PDF 報告、發票、導出文件等。 項目介紹 QuestPDF 是一個革命性的開源 .NET 庫,它徹底改變了我們生成 PDF 文檔的方 ...
  • 項目地址 項目後端地址: https://github.com/ZyPLJ/ZYTteeHole 項目前端頁面地址: ZyPLJ/TreeHoleVue (github.com) https://github.com/ZyPLJ/TreeHoleVue 目前項目測試訪問地址: http://tree ...
  • 話不多說,直接開乾 一.下載 1.官方鏈接下載: https://www.microsoft.com/zh-cn/sql-server/sql-server-downloads 2.在下載目錄中找到下麵這個小的安裝包 SQL2022-SSEI-Dev.exe,運行開始下載SQL server; 二. ...
  • 前言 隨著物聯網(IoT)技術的迅猛發展,MQTT(消息隊列遙測傳輸)協議憑藉其輕量級和高效性,已成為眾多物聯網應用的首選通信標準。 MQTTnet 作為一個高性能的 .NET 開源庫,為 .NET 平臺上的 MQTT 客戶端與伺服器開發提供了強大的支持。 本文將全面介紹 MQTTnet 的核心功能 ...
  • Serilog支持多種接收器用於日誌存儲,增強器用於添加屬性,LogContext管理動態屬性,支持多種輸出格式包括純文本、JSON及ExpressionTemplate。還提供了自定義格式化選項,適用於不同需求。 ...
  • 目錄簡介獲取 HTML 文檔解析 HTML 文檔測試參考文章 簡介 動態內容網站使用 JavaScript 腳本動態檢索和渲染數據,爬取信息時需要模擬瀏覽器行為,否則獲取到的源碼基本是空的。 本文使用的爬取步驟如下: 使用 Selenium 獲取渲染後的 HTML 文檔 使用 HtmlAgility ...
  • 1.前言 什麼是熱更新 游戲或者軟體更新時,無需重新下載客戶端進行安裝,而是在應用程式啟動的情況下,在內部進行資源或者代碼更新 Unity目前常用熱更新解決方案 HybridCLR,Xlua,ILRuntime等 Unity目前常用資源管理解決方案 AssetBundles,Addressable, ...
  • 本文章主要是在C# ASP.NET Core Web API框架實現向手機發送驗證碼簡訊功能。這裡我選擇是一個互億無線簡訊驗證碼平臺,其實像阿裡雲,騰訊雲上面也可以。 首先我們先去 互億無線 https://www.ihuyi.com/api/sms.html 去註冊一個賬號 註冊完成賬號後,它會送 ...
  • 通過以下方式可以高效,並保證數據同步的可靠性 1.API設計 使用RESTful設計,確保API端點明確,並使用適當的HTTP方法(如POST用於創建,PUT用於更新)。 設計清晰的請求和響應模型,以確保客戶端能夠理解預期格式。 2.數據驗證 在伺服器端進行嚴格的數據驗證,確保接收到的數據符合預期格 ...