2016 年青島網路賽---Tea

来源:http://www.cnblogs.com/chen9510/archive/2016/09/17/5879710.html
-Advertisement-
Play Games

題目鏈接 http://acm.hdu.edu.cn/showproblem.php?pid=5881 Problem Description Tea is good.Tea is life.Tea is everything.The balance of tea is a journey of p ...


題目鏈接

http://acm.hdu.edu.cn/showproblem.php?pid=5881

 

Problem Description Tea is good.

Tea is life.

Tea is everything.

The balance of tea is a journey of pursuing balance of the universe.

Alice knows that. 

Alice wants to teach you the art of pouring tea.

Alice has a pot of tea.

The exact volume of tea is not important.

The exact volume of tea is at least L.

The exact volume of tea is at most R.

Alice put two empty cups between you and her.

Alice wants the two cups filled by almost equal volume of tea.

Yours cannot be 1 unit more than hers.

Hers cannot be 1 unit more than yours.

Alice wants you to pour the tea.

Alice wants you to pour until the pot is almost empty.

Alice wants no more than 1 unit volume of tea remaining in the pot.

You cannot read the residue volume of tea remaining in the pot.

You can only know the tea status in the pot, empty or not.

Alice does not want you to pour the tea too many times.

You better pour as few times as possible.
  Input There are multiple cases.
For each case, there is one line of two integers L and R, separated by single space.

Here are some analyses about sample cases.
For the first case, pouring 1 unit into one cup will satisfy Alice.
For the second case, it is clearly that you cannot only pour once to reach the desired balance, but she can achieve it by pouring twice.
First you pour 1.5 units into one cup, then you attempt to pour another 1.5 units into the other cup.
Since the lower bound is 2, at least 0.5 unit remains in the pot after the first pouring.
If the initial volume is in range [2,3], the second cup will have volume in range [0.5,1.5] which is balanced with 1.5 unit in the first cup, and at most 1 unit remain after these two attempts.

About 1000 test cases, and 0LR1016.
  Output For each case, there should be a single integer in a single line, the least number of pouring attempts.   Sample Input 2 2 2 4   Sample Output 1 2   Source 2016 ACM/ICPC Asia Regional Qingdao Online  

 

Recommend wange2014   |   We have carefully selected several similar problems for you:  5891 5890 5889 5887 5886    題意:輸入L,R 表示一壺茶的茶的體積的範圍L~R,不確定精確量(整數), 現在往兩個茶杯中倒茶(不考慮茶杯容量) ,要求使兩個茶杯中茶相差不超過1 ,而茶壺中剩餘的茶不能超過1, 求最少倒茶的次數;         樣例解釋一下:2 2 答案是1 ,我們可以往第一個茶杯中倒1 ,第二杯不倒, 那麼兩個茶杯相差為1 ,茶壺剩餘量為0~1 , 符合題目要求; 2 4 答案是2 ,我們可以往第一杯倒入1.5  那麼第二杯按1.5 到,如果茶壺 茶量為2,那麼第二杯倒入0.5 兩倍相差1 茶壺為0 符合題目要求,如果茶壺 茶量為4, 第二杯倒入1.5 兩杯量相同, 茶壺剩餘1, 符合題目要求;   思路: 先考慮普通情況,第一杯倒入(L+1)/2, 第二杯按照(L+1)/2+1倒, 那麼如果茶壺量為L<=茶壺<=L+2 ,則茶壺為0 了,兩杯茶相差0~1 ;如果情況糟糕茶壺不空,那麼接下來往第一杯中倒入2 ,第二杯中倒入2 ,第一杯中倒入2 ......知道茶壺不足2 (即茶壺剩餘量為0或者1) ,這樣兩杯茶始終相差1,符合題意;   代碼如下:
#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <queue>
#include <cmath>
#include <string.h>
using namespace std;

int main()
{
    long long L,R;
    while(scanf("%lld%lld",&L,&R)!=EOF)
    {
        if(L==R)
        {
            if(R<=1) puts("0");
            else if(R==2) puts("1");
            else puts("2");
            continue;
        }
        if(L==0)
        {
            if(R==1) puts("0");
            else if(R==2) puts("1");
            else printf("%lld\n",(R+1)/2);
        }
        else
        {
            if(L==1&&R==2)  puts("1");
            else{
            if(L+2>=R-1) puts("2");
            else printf("%lld\n",(R-L+2)/2);
            }
        }
    }
    return 0;
}

 


您的分享是我們最大的動力!

-Advertisement-
Play Games
更多相關文章
  • 類的基本成員才有預設值 finalize()並非析構,Java中沒有析構,使用finalize()通常在於跨語言調用情景:比如使用C進行malloc記憶體分配以後,要在finalize()方法中進行free,以便於提供一種記憶體釋放的方法,否則當量達到一定程度時會造成out of memories。Jv ...
  • 介紹一個生成動態鏈接庫*.so的例子: 首先新建1個頭文件test.h: 然後新建3個源文件first.c/second.c/third.c: first.c: second.c: third.c: 然後,生成動態鏈接庫libtest.so: gcc first.c second.c third.c ...
  • 編譯環境:windows 7 64位 編譯工具:codeblocks 13.12 備註:未使用graphics.h 聲明:個人原創,未經允許,禁止轉載!!! 數據結構:雙向鏈表 1.程式未使用graphis.h中的 函數,所以採用先清屏,再列印的方式顯示圖形,大約每秒刷新一次; 2.除蛇頭元素外,其 ...
  • 在EL表達式中,假設某個entity的status屬性為char類型,此處假設為'1',在jsp中,對於${entity.status=='1'},我們預期的結果是true,但實際上是false - -! why?是這樣的,EL表達式比較偷懶,把char類型數據做了自動轉型,所以上面的EL換一種寫法 ...
  • 建議52:推薦使用String直接量賦值 一般對象都是通過new關鍵字生成的,但是String還有第二種生成方式,也就是我們經常使用的直接聲明方式,這種方式是極力推薦的,但不建議使用new String("A")的方式賦值。為什麼呢?我們看如下代碼: 註意看上面的程式,我們使用"=="判斷的是兩個對 ...
  • 1.如何獲取某個方法 方法的名稱和方法的參數列表才能唯一決定一個方法 2.方法反射的操作 method.invoke(); 如果方法是private的會報這個錯誤 java.lang.IllegalAccessException ...
  • carbaugh/lice "lice" : Generate license files for your projects 一個用來為你的項目生成許可證的工具。這下可方便了,不用手工的去修改了! coleifer/peewee "peewee" : a small, expressive orm ...
  • 一、首先先在碼雲上新建一個項目 二、複製項目的鏈接 三、打開SmartGit,點擊clone 4、把複製的項目鏈接粘上去 5、然後點兩次next,選擇一個路徑,finish 6、打開剛剛選擇的路徑,我們能看到: 7、現在我們要把我們自己的maven項目粘進去 8、做完之後,我們能夠看到SmartGi ...
一周排行
    -Advertisement-
    Play Games
  • 移動開發(一):使用.NET MAUI開發第一個安卓APP 對於工作多年的C#程式員來說,近來想嘗試開發一款安卓APP,考慮了很久最終選擇使用.NET MAUI這個微軟官方的框架來嘗試體驗開發安卓APP,畢竟是使用Visual Studio開發工具,使用起來也比較的順手,結合微軟官方的教程進行了安卓 ...
  • 前言 QuestPDF 是一個開源 .NET 庫,用於生成 PDF 文檔。使用了C# Fluent API方式可簡化開發、減少錯誤並提高工作效率。利用它可以輕鬆生成 PDF 報告、發票、導出文件等。 項目介紹 QuestPDF 是一個革命性的開源 .NET 庫,它徹底改變了我們生成 PDF 文檔的方 ...
  • 項目地址 項目後端地址: https://github.com/ZyPLJ/ZYTteeHole 項目前端頁面地址: ZyPLJ/TreeHoleVue (github.com) https://github.com/ZyPLJ/TreeHoleVue 目前項目測試訪問地址: http://tree ...
  • 話不多說,直接開乾 一.下載 1.官方鏈接下載: https://www.microsoft.com/zh-cn/sql-server/sql-server-downloads 2.在下載目錄中找到下麵這個小的安裝包 SQL2022-SSEI-Dev.exe,運行開始下載SQL server; 二. ...
  • 前言 隨著物聯網(IoT)技術的迅猛發展,MQTT(消息隊列遙測傳輸)協議憑藉其輕量級和高效性,已成為眾多物聯網應用的首選通信標準。 MQTTnet 作為一個高性能的 .NET 開源庫,為 .NET 平臺上的 MQTT 客戶端與伺服器開發提供了強大的支持。 本文將全面介紹 MQTTnet 的核心功能 ...
  • Serilog支持多種接收器用於日誌存儲,增強器用於添加屬性,LogContext管理動態屬性,支持多種輸出格式包括純文本、JSON及ExpressionTemplate。還提供了自定義格式化選項,適用於不同需求。 ...
  • 目錄簡介獲取 HTML 文檔解析 HTML 文檔測試參考文章 簡介 動態內容網站使用 JavaScript 腳本動態檢索和渲染數據,爬取信息時需要模擬瀏覽器行為,否則獲取到的源碼基本是空的。 本文使用的爬取步驟如下: 使用 Selenium 獲取渲染後的 HTML 文檔 使用 HtmlAgility ...
  • 1.前言 什麼是熱更新 游戲或者軟體更新時,無需重新下載客戶端進行安裝,而是在應用程式啟動的情況下,在內部進行資源或者代碼更新 Unity目前常用熱更新解決方案 HybridCLR,Xlua,ILRuntime等 Unity目前常用資源管理解決方案 AssetBundles,Addressable, ...
  • 本文章主要是在C# ASP.NET Core Web API框架實現向手機發送驗證碼簡訊功能。這裡我選擇是一個互億無線簡訊驗證碼平臺,其實像阿裡雲,騰訊雲上面也可以。 首先我們先去 互億無線 https://www.ihuyi.com/api/sms.html 去註冊一個賬號 註冊完成賬號後,它會送 ...
  • 通過以下方式可以高效,並保證數據同步的可靠性 1.API設計 使用RESTful設計,確保API端點明確,並使用適當的HTTP方法(如POST用於創建,PUT用於更新)。 設計清晰的請求和響應模型,以確保客戶端能夠理解預期格式。 2.數據驗證 在伺服器端進行嚴格的數據驗證,確保接收到的數據符合預期格 ...